[vpn-help] Fwd: Re: Fwd: Re: Starting the GUI

Albrecht Mehl mehl at freunde.tu-darmstadt.de
Fri Mar 26 08:31:03 CDT 2010

Dear Matthew,

thank you very much for your reply.

Am 25.03.2010 22:56, schrieb Matthew Grooms:
> On 3/25/2010 4:13 AM, Albrecht Mehl wrote:
>> -------- Original-Nachricht --------
>> Betreff: Re: [vpn-help] Fwd: Re:  Starting the GUI
>> Datum: Thu, 25 Mar 2010 10:12:44 +0100
>> Von: Albrecht Mehl<mehl at freunde.tu-darmstadt.de>
>> An: Matthew Grooms<mgrooms at shrew.net>
>> Dear Matthew,
>> thank you very much for your reply. Unfortunately I have still not succeded.
> Did you run cmake with the recommended command line parameters for the 
> Linux platform ( as documented in README.TXT )?
> Without -DQTGUI=YES specified, the gui components will not be compiled 
> when you run make.

Shame on me ... I made a mistake while compiling. Now I think I got that
straightened out ... but I still cannot open the scripts.

I started the compilation by


001109ea63a6:/usr/local/bin/shrewvpn/ike # cmake


At the end of the make install the output was


Linking CXX executable CMakeFiles/CMakeRelink.dir/iked
Linking CXX executable CMakeFiles/CMakeRelink.dir/ikea
Linking CXX executable CMakeFiles/CMakeRelink.dir/ikec
Install the project...
-- Install configuration: ""
-- Installing: /usr/sbin/iked
-- Up-to-date: /usr/local/man/man8/iked.8
-- Up-to-date: /usr/local/man/man5/iked.conf.5
-- Up-to-date: /etc/iked.conf.sample
-- Installing: /usr/lib/libike.so.2.1
-- Installing: /usr/lib/libike.so
-- Installing: /usr/lib/libpfk.so.2.1
-- Installing: /usr/lib/libpfk.so
-- Installing: /usr/bin/ikea
-- Up-to-date: /usr/local/man/man1/ikea.1
-- Installing: /usr/bin/ikec
-- Up-to-date: /usr/local/man/man1/ikec.1
001109ea63a6:/usr/local/bin/shrewvpn/ike #


I then tried in vain to open iked:


001109ea63a6:/usr/sbin # ./iked
./iked: error while loading shared libraries: libike.so.2.1: cannot open
shared object file: No such file or directory
001109ea63a6:/usr/sbin #


This file libike.so.2.1 is in /usr/lib/ indeed, so I have no idea why it
cannot be found. A helpful hint what to do next would be most welcome.


A. Mehl
Albrecht Mehl	    |
Schorlemmerstr. 33  |Tel. (06151) 37 39 92
D-64291 Darmstadt, Germany|sehenswert - ungefähr 'Wir einsam im All'

More information about the vpn-help mailing list