[vpn-help] Shrew Client and routing through AVM Fritz Router7270

Rainer Budde rbudde at rwh-ia.de
Tue Mar 9 02:02:48 CST 2010

Dear all,


thank you all for your replies. My colleague has a network adapter which called "Microsoft Virtual Wifi Miniport Adapter". I deactivated the adapter and everything works without any problems. For this reason this problem is solved for me.


This might be a little bit OT: I was very surprised about this "new" adapter and I searched for information about it in the internet. But I don't found the information when the adapter will be installed by Microsoft automatically. Does anybody know when the adapter will be installed (maybe if the notebook was connected to several wifi networks)?


Kind regards


Rainer Budde


Rainer Budde

Software Engineering


RWH Industrieautomatisierung GmbH

Emsteker Strasse 14-16

D-49661 Cloppenburg


Fon: +49 (0) 4471 - 9293 -18

Fax: +49 (0) 4471 - 9293 -22

Mail: rbudde at rwh-ia.de


Geschäftsführer: Andreas Reuter, Amtsgericht Oldenburg, HRB 151141


This e-mail and any files transmitted with it are confidential and are intended solely for the use of the individual or entity to whom they are addressed. This communication represents the originator's personal views and opinions, which do not necessarily reflect those of RWH Industrieautomatisierung GmbH or any of its subsidiaries or affiliates. If you are not the original recipient or the person responsible for delivering the e-mail to the intended recipient, be advised that you have received this e-mail in error, and that any use, dissemination, forwarding, printing or copying this e-mail is strictly prohibited. If you receive this e-mail in error, please immediately notify mail at rwh-ia.de


Von: vpn-help-bounces at lists.shrew.net [mailto:vpn-help-bounces at lists.shrew.net] Im Auftrag von Linwood Ferguson
Gesendet: Montag, 8. März 2010 13:46
An: vpn-help at lists.shrew.net
Betreff: Re: [vpn-help] Shrew Client and routing through AVM Fritz Router7270


>>But if he is connected to the Wireless LAN he couldn't access to the VPN-Router (LANCOM 1711+ latest firmware). 


>>He can ping the LANCOM VPN-Router and he can access to all other internet services


>> but if he try to make a VPN connection the connection immediately fails with the


>> message "negotiation timeout" and "detach from the key daemon". 


>From prior reactions from the list I may be the only one with this symptom and solution but you may want to try it.   I found that in Windows 7 there is an automatically created "Microsoft virtual Wifi Miniport Adapter".  This is a new "feature" in W7 and is not necessary to use Wifi.  


I had similar symptoms to the above, plus DNS resolution failures (when not connected), and disabling the above adapter fixed them 100%.


Note you cannot just delete the device - it is recreated every time you enable the physical wifi adapter.  But if you disable it, it remembers and says disabled.


You might give it a try.  I have no explanation to offer for it, just that it worked for me.





PS. In my case everything worked fine with it not disabled for weeks, then all of a sudden it quit working entirely and only started again when I disabled the adapter, despite reboots, de-and-re-install of the software, different versions, etc.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.shrew.net/pipermail/vpn-help/attachments/20100309/ebf08ed0/attachment-0002.html>

More information about the vpn-help mailing list